フォーラム掲示板について

以下の目的、注意点などご確認いただき、ご使用ください。

目的
Connect-CMSのユーザやConnect-CMSに興味のある方同士で自由に意見交換できる場を提供する目的で、コミュニティ掲示板として提供しています。
投稿方法
このサイトにユーザー登録することで、投稿することができます。
投稿内容
投稿内容は公開されます。
Connect-CMSに無関係な内容が記載されたと判断した場合、削除することがあります。

フォーラム掲示板

Xserverへのインストール…その後。

2021年2月21日 10時12分 [MTS]

2/18アップデートに際して、改めてPHPのバージョンがさらに上を要求されたので、

Xserverの仕様を読み返しておりました。前回は、上のような方法でやっていましたが、
バージョンアップごとにするには煩雑なので、コマンドのPHPのあとにバージョンを付記すればよいようです。

例えばバージョン7.3以上が要求されるときは「php7.3 -d allow_url_fopen=1 ...」
のようにすればスムーズにインストール及びアップデートができました。

以上、ご報告します。

スレッドの記事一覧
※問い合わせフォームからお送りしたものを、再掲しています。

永原さんの勉強会でのデモを見て、さくらレンタルサーバーのインストール方法を見ながら自分でXserverへのインストールを試みてみました。 コンポーザーのダウンロードとバージョンダウンまではうまくいくのですが、肝心のコンポーザーのインストールがうまくいきません。 エラーメッセージでは、phpのバージョンが違うとのメッセージですが、PHPは7.4.13で設定しています。 コンポーザーのインストールを行った行の下に、このメッセージが流れました。 our requirements could not be resolved to an installable set of packages. Problem 1 - This package requires php >=7.2.0 but your PHP version (5.4.16) does not satisfy that requirement. Problem 2 - Installation request for azuyalabs/yasumi 2.3.0 -> satisfiable by azuyalabs/yasumi[2.3.0]. - azuyalabs/yasumi 2.3.0 requires php >=7.2 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 3 - Installation request for bensampo/laravel-enum 1.19 -> satisfiable by bensampo/laravel-enum[1.19]. - bensampo/laravel-enum 1.19 requires php ~7.1 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 4 - Installation request for doctrine/cache 1.10.2 -> satisfiable by doctrine/cache[1.10.2]. - doctrine/cache 1.10.2 requires php ~7.1 || ^8.0 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 5 - Installation request for doctrine/dbal 2.10.2 -> satisfiable by doctrine/dbal[2.10.2]. - doctrine/dbal 2.10.2 requires php ^7.2 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 6 - Installation request for doctrine/event-manager 1.1.0 -> satisfiable by doctrine/event-manager[1.1.0]. - doctrine/event-manager 1.1.0 requires php ^7.1 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 7 - Installation request for doctrine/inflector 1.3.1 -> satisfiable by doctrine/inflector[1.3.1]. - doctrine/inflector 1.3.1 requires php ^7.1 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 8 - Installation request for doctrine/lexer 1.2.0 -> satisfiable by doctrine/lexer[1.2.0]. - doctrine/lexer 1.2.0 requires php ^7.2 -> your PHP version (5.4.16) does not satisfy that requirement. Problem 9 Xserverでは、PHPのバージョンをサーバーパネルから選択できるようになっています。上記のように推奨バージョンの設定にしてあるのですが、エラーメッセージではどうも違うバージョンのPHPが実行されているようです。
同様に、Xserver側にも問い合わせてみようと思います。

こんにちは。
永原です。

Xserver、Web用のPHP とコマンドのPHP のバージョンが異なるようですね。

「xserver php composer」で検索してみると、対応方法などが出てきました。

私はXserver を使っていないので、どれが正解かわからないのですが、検索してみた結果で、試していただけないでしょうか。

うまく行ったものがあれば、紹介していただければうれしいです。

ダメだったらダメで、エラー内容など教えていただければ、何かアドバイスできるかもしれません。

以上

永原さん、ご回答ありがとうございます。

Xserverではホームページ用とコマンドでは、PHPが違うらしくPHPのバージョンをサーバーパネルで変えても意味がないことがわかりました。

教えていただいた、検索ワードでいくつか調べてコマンドのphpをあげてそこにパスを通すということをして、PHPを7.2.14にしました。インストールについては最後までいったのですが、サイトを表示しようとすると

アクセスしようとしたページは表示できませんでした。このエラーは、表示するページへのアクセス許可がなかったことを意味します。

という風に、403エラーが発生します。

さくらでない方のインストールページにあった、パーミッションの変更については設定しています。

もう一息というところです。無事できましたら、方法を書き込みたいです。

永原です。

インストールはできたようですね。
さくらのレンタルサーバとXserver では、公開エリアに対する設定方法が違うのかも知れないですね。

「xserver laravel」で検索すると、いろいろと出てきます。
Laravel は、Connect-CMS が採用しているフレームワークです。
サイトの公開に関する設定ということなら、Connect-CMS というよりは、そのフレームワークであるLaravel に関する設定ということになります。

public ディレクトリへの設定について、何か必要なんだと思います。

以上

ありがとうございました。

結果的に、最後のリンクを設定するところをどうも読み飛ばしていまして、そこを設定するとトップページが表示されるようになりました。

教えていただきまして、ありがとうございました。

また勉強会では宜しくお願いします!

Xserverにインストールされる際は、PHPのバージョンにご注意ください。

Xserverでは、サーバーパネルで指定できるのはWEBアクセス時のPHPバージョンであって、SSH接続でのPHPとは無関係となっています。(Xserverのサポートにも確認済み)

そのため、サポートからはパス指定をするようにと言われましたが、永原さんに教えていただいた検索ワードで調べました。

私としては、以下のページが参考になりました。

helog  https://helog.jp/server/xserver-composer-php/

です。

こうして、PHPのバージョンを要求される7.2.5以上にしてから、さくらのレンタルサーバーのインストール手順を見ながら(ディレクトリは適宜自分の環境に合わせて)インストールできます。

以上です。

Xserverへのインストール…その後。
2021-02-21 [MTS]

2/18アップデートに際して、改めてPHPのバージョンがさらに上を要求されたので、

Xserverの仕様を読み返しておりました。前回は、上のような方法でやっていましたが、
バージョンアップごとにするには煩雑なので、コマンドのPHPのあとにバージョンを付記すればよいようです。

例えばバージョン7.3以上が要求されるときは「php7.3 -d allow_url_fopen=1 ...」
のようにすればスムーズにインストール及びアップデートができました。

以上、ご報告します。